Socket Error # 10054 - Connection reset by peer

Probleme oder Fragen zur Installation, Update und Netzwerkanbindung
Antworten

Socket Error # 10054 - Connection reset by peer

Hallo zusammen,

ich habe ein etwas merkwürdiges Problem und zwar kann ich keinen "Shoptransfer" mehr durchführen. Wenn ich bspw. Update CAO -> SHOP oder auch "Lese Script-Versionen" aufrufe kommen die Fehlermeldungen, die in den Bildern im Anhang oder auch im Titel zu sehen/lesen sind. Im gleichen Netzwerk stehen noch 2 PCs, von denen aus alles bestens funktioniert.

Überprüft habe ich bereits folgendes:
- Windows Firewall testweise deaktiviert
- Server Erreichbarkeit geprüft
- Berechtigungen auf export Verzeichnis
- URL / Zugangsdaten geprüft

Hat jemand vielleicht noch Ideen?

Danke, mfg

Edit: Über den Fehler bin ich hier im Forum schon ein paar mal gestolpert, allerdings haben die Lösungsansätze nichts gebracht.
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Re: Socket Error # 10054 - Connection reset by peer

Hi,

* Was passiert, wenn du das Shop-Script im Browser aufrufst?
* Ist auf dem Rechner ein AV Programm, welches sich in die HTTP Verbindung einklinkt?
* Ich würde URL und Zugangsdaten trotzdem nochmal komplett neu reinschreiben
Gruss Axel

Re: Socket Error # 10054 - Connection reset by peer

Hi, interessanterweise tritt der Fehler seit dem letzten Update bei mir auch sporadisch auf.
Ein Neustart von CAO hilft dann hier und ich kann den Transfer, egal in welche Richtung, wieder durchführen.

Allerdings ist es schon ziemlich nervig.
Allerbeste Grüße und Dankeschön vom Chris
------------------------------------------
https://www.meinestruempfe.de
OXID
CAO
Variantenmodul
Auftragsbearbeitung
Stapeldruck

Re: Socket Error # 10054 - Connection reset by peer

* Was passiert, wenn du das Shop-Script im Browser aufrufst?
Ich vermute du meinst das Export-Script? Ich bekomme die ganz normale Ausgabe mit einigen Informationen wie Version und Datum zu sehen.

* Ist auf dem Rechner ein AV Programm, welches sich in die HTTP Verbindung einklinkt?

Avira Antivir ist installiert, allerdings habe ich das auch schonmal testweise deaktiviert. Hat aber nichts gebracht.

* Ich würde URL und Zugangsdaten trotzdem nochmal komplett neu reinschreiben

Habe ich jetzt mal noch per Hand beides eingegeben.. immer noch das selbe Problem.

coarsy hat geschrieben:Hi, interessanterweise tritt der Fehler seit dem letzten Update bei mir auch sporadisch auf.
Ein Neustart von CAO hilft dann hier und ich kann den Transfer, egal in welche Richtung, wieder durchführen.

Allerdings ist es schon ziemlich nervig.
Neustart hilft bei mir leider auch nichts :(

Re: Socket Error # 10054 - Connection reset by peer

Ich habe es gerade auch mal noch mit einer "Testumgebung" des Shops versucht, da funktioniert es.

- Es liegt also nicht am Server/Shop, da der Transfer von den anderen PCs ja klappt (sehr selten funktioniert es auch mal auf diesem einen PC)?
- Es liegt also nicht am Client/PC selbst, da der Transfer auf die "Testumgebung" klappt?

:?: :?:

Re: Socket Error # 10054 - Connection reset by peer

Ich habe nach Update auf Avira Antivirus Pro 2015 die gleichen Probleme gehabt.

Die Quick&Dirty-Lösung:
=> Browser Schutz abschalten.

Die richtige Lösung:
=> Ausnahmen von "Geblockte Webseiten" im Antivirus definieren. Wie das geht steht hier:
http://www.avira.com/de/support-for-hom ... /kbid/1387
Einfach die Domain eingeben, von der der Transfer gemacht wird.

Als ich das gemacht hatte, hatte ich allerdings das Problem, daß die Firewall auf einmal meinen DB Port zugemacht hat. Warum das im Zusammenhang steht verstehe ich nicht. Die Lösung hierfür war eine Ausnahme in der Windows Firewall zu definieren.
http://maximumpcguides.com/windows-7/op ... -firewall/

Re: Socket Error # 10054 - Connection reset by peer

Hallooo Zusammen,

ich wollte mal Fragen was sich bzgl. dieser Problematik in CAO 1.5 verändert hat um rauszufinden, ob wir ein aktuelles Problem damit lösen könnten.

Im Folgenden zum Verständnis der aktuelle Sachverhalt, also ...

Der Kunde nutzt aktuell noch CAO (K) 1.4.5.7 da ein Upgrade auf 1.5 aufgrund folgender Thematik bisher noch nicht möglich war ...
viewtopic.php?f=47&t=5825

Nun haben wir die Schnittstelle des Kunden angepasst - aufgrund der folgenden SSL-Thematik (Proxy-Schnittstelle für TLS 1.x Support) ...
viewtopic.php?f=32&t=5784

Vorher war die URL der Schnittstelle also ins Internet adressiert. Und nun auf eine lokale IP.

Die Synchronisation funktioniert nach wie vor. Jedoch nach 2 Minuten Inaktivität in CAO-Faktura führt dann der Abgleich nun auf einmal genau zu diesem im Beitrag beschriebenen Fehler. Dies kann dann nur noch mit einem Neustart von CAO-Faktura behoben werden. (Der Fehler ansich wäre gar nicht so tragisch, wenn man nicht diesen Neustart ausführen müsste. Da dies dann natürlich sehr sehr oft während eines Tages erforderlich ist.)

Die im folgenden durchgeführte Maßnahmen haben alle nichts gebracht:
- Firewall, Virenscanner auf Server und Client deaktiviert
- interner Zugriff auf diese Proxy-Schnittstelle über http und auch über https (mit selbstsigniertem Zertifikat)
- Proxy-Schnittstelle kurz vor Abgleich neu gestartet
- Der Zugriff auf die Schnittstelle zum gleichen Zeitpunkt direkt von einem Browser aus (vom Client oder Server aus) funktioniert immer.

Was ich dann gar nicht verstehe. Das Problem tritt auch auf allen Clients in der Firma auf mit unterschiedlichen Betriebssystemen. Vielleicht gibts dann doch noch irgendeinen Zusammenhang mit Windows-Domäne, Router etc. (einen Proxy gibt es nicht). Ansonsten leider alles nicht meine Baustelle ... aber irgendwas ist da sicher ganz stark faul (auch aufgrund dieser Thematik: viewtopic.php?f=47&t=5825)

Wenn man diese Infrastruktur (CAO->Proxy-Schnittstelle->Shop-Schnittstelle) auf einem unabhängigen Rechner nachbaut gibt ebenfalls es keine Probleme.

Dann noch zur Information wie ich den Fehler auch in CAO 1.5 nachstellen kann:
Wenn man diese Proxy-Schnittstelle oder z. B. auch die neue Shopware Schnittstelle debugged, und dann während dessen einfach killt, dann erhält man ebenfalls diesen Fehler in CAO. Was natürlich logisch ist. Aber auch hier lässt sich das ganze eben dann auch nur noch mit einem Neustart von CAO wieder zurücksetzen. Das nur zur Info. Denn könnte man nach einem Verbindungsabbruch wieder weitermachen, dann wäre das ganze wie gesagt nicht mehr wirklich tragisch.

So, Entschuldigung dass der Text so lange geworden ist ...

Ich wäre wirklich sehr dankbar um jeden Tip, der irgendwie helfen könnte ... oder hat vielleicht jemand Interesse, dass er sich das im Auftrag mal anschaut?

LG
Florian
Beste Grüße
Florian Feilmeier
FFE-Tech e. U.
SOFTWAREentwicklung

https://www.ffe-tech.com
info@ffe-tech.com

Re: Socket Error # 10054 - Connection reset by peer

Hallo,

meine Antwort ist etwas kürzer :)
Welche SSL Librarys werden genutzt? (libeay32.dll, ssleay32.dll aus dem CAO-Faktura-Install Verzeichnis)

Erfahrungsgemäß können da "falsche" bzw. "alte" oder "zu neue" Probleme mit der Verbindung verursachen.
Gruß Chris
"Derjenige, der sagt: "Es geht nicht", soll den nicht stören, der's gerade tut."

Re: Socket Error # 10054 - Connection reset by peer

Hallo Chris,

Vielen Dank für deine schnelle Antwort :)

Es sollten genau die Dateien sein, die mit CAO (K) 1.4.5.7 ausgeliefert wurden.

Sollte das aber nicht egal sein, wenn man auf die lokale IP-Adresse per http (also ohne ssl) zugreift? (Per https hatte ich nur mal ausprobiert, in der Hoffnung, das es vielleicht was verändern könnte)

Ansonsten kann ich die Versionen der Dateien gerne nochmal nachschauen.
Beste Grüße
Florian Feilmeier
FFE-Tech e. U.
SOFTWAREentwicklung

https://www.ffe-tech.com
info@ffe-tech.com

Re: Socket Error # 10054 - Connection reset by peer

Ich habe nur irgendwo TLS gelesen, daher die Anmerkung. Sollte http das Protokoll sein, ist das natürlich hinfällig.

Die Entwicklungsumgebung von CAO nutzt Komponenten die teils sehr Zickig sind.
Kann denn ausgeschlossen werden, dass eine Firewall die Kommunikation stört?

Beim Debuggen tritt der Fehler aufgrund von Timeouts auf. Ich vermute auch da einen zu kleinen Wert. Das prüfe ich mal.
Gruß Chris
"Derjenige, der sagt: "Es geht nicht", soll den nicht stören, der's gerade tut."

Re: Socket Error # 10054 - Connection reset by peer

Hi Chris,

Ja, Firewall, Virenscanner und sonstiges Teufelszeug :) alles deaktiviert.

Bzgl. Debugging glaub ich nicht, das ein Timeout die Ursache ist. Also die Debugging-Sitzung während eines Requests kann ruhig ewig dauern, das ist kein Problem. Ich meinte nur, wenn ich die Sitzung mal abschieße dann kommts logischerweise zu dem gleichen Fehler, denn da hab ich dann ja die Verbindung wirklich fahrlässig zerstört. Worauf ich hinauswollte ist, dass man da dann nur wieder rauskommt, wenn man CAO neu startet. Der Fehler ansich wäre nicht so tragisch, wenns beim nächsten Versuch wieder klappen würde. Der Neustart vielmals täglich tut hald weh.

Kann es sein, dass das das HTTPRequest Objekt global instantiiert wird und deshalb bei diesem Fehler der Status nicht zurückgesetzt wird.

Darf ich fragen, bei welcher Delphi Version ihr momentan seid. Borland 7 oder schon Embarcadero. Ich bin nicht mehr auf dem Laufenden. Ist schon ne Weile her meine Delphi Zeit :)
Beste Grüße
Florian Feilmeier
FFE-Tech e. U.
SOFTWAREentwicklung

https://www.ffe-tech.com
info@ffe-tech.com

Re: Socket Error # 10054 - Connection reset by peer

ffetech hat geschrieben: Sa 7. Mär 2020, 20:00 Darf ich fragen, bei welcher Delphi Version ihr momentan seid. Borland 7 oder schon Embarcadero. Ich bin nicht mehr auf dem Laufenden. Ist schon ne Weile her meine Delphi Zeit :)
Beides. Allerdings nutzen beide Versionen die aktuellsten TCP/IP Komponenten.

Ich muss trotzdem nochmal auf SSL rumreiten. CAO erkennt nicht ob http oder https genutzt wird. Im Registry-Editor von CAO im Hauptschlüssel SHOP - Gibts da den Wert SSL und ist dieser auf 1 gestellt?

Mit dem Debugging habe ich andere Erfahrugen gemacht. Der Request in CAO hat einen Timeout, sollte auf der Shopseite ein Debugger keine Antwort geben, wird die Verbindung von CAO Zerstört. Es wird hart aufgelegt, daher Connection reset by peer. Das darf sonst natürlich nicht sein.
Gruß Chris
"Derjenige, der sagt: "Es geht nicht", soll den nicht stören, der's gerade tut."

Re: Socket Error # 10054 - Connection reset by peer

Hallo Chris,

danke für den Tip. Da hab ich gar nicht dran gedacht, da es ja generell schon funktioniert hatte. Nur nach einer Wartezeit kam dann bei erneutem Transfer der Fehler.

Die Einstellung SSL habe ich jetzt geändert auf 0. CAO neu gestartet. Der Fehler kam dann aber immer noch. Aber nun nur noch wenn man innerhalb des Shoptransfer-Moduls 2 min. wartet.

Jetzt verhält es sich aber anders, wenn man zwischendurch in andere Module (z. B. die Artikelverwaltung) wechselt. Wenn man dann wieder zurück in den Shoptransfer geht, dann funktionierts sofort. Und das hilft natürlich jetzt enorm, da dies ja auch zu 95% das Standardvorgehen ist.

Deshalb vielen lieben Dank für deine Hilfe :)

Vielleicht kann man in CAO 1.5 da trotzdem nochmal was machen. Sofern der Fehler mal auftreten sollte, dass dann keine Neustart von CAO notwendig ist.

Ich wünsch Dir noch einen schönen Sonntag und nochmals vielen lieben Dank für deine Unterstützung :)

LG
Florian
Beste Grüße
Florian Feilmeier
FFE-Tech e. U.
SOFTWAREentwicklung

https://www.ffe-tech.com
info@ffe-tech.com